Reef Central Online Community

Home Forum Here you can view your subscribed threads, work with private messages and edit your profile and preferences View New Posts View Today's Posts

Find other members Frequently Asked Questions Search Reefkeeping ...an online magazine for marine aquarists Support our sponsors and mention Reef Central

Go Back   Reef Central Online Community > Sponsor Forums > SpectraPure
Register Blogs FAQ Calendar Mark Forums Read

Notices

User Tag List

Reply
Thread Tools
Old 08/19/2018, 12:19 AM   #1
Tigé21v
Registered Member
 
Tigé21v's Avatar
 
Join Date: Apr 2008
Location: St. Charles, Mo.
Posts: 1,365
Issue with new Spectra Select

I ordered a new spectra select 90 gpd membrane through Premium Aquatics.
I'm about 100 gallons of water through the membrane. Have run 3 cycles, each about 30 gallons. 235ppm (+/-) tds going into the filter, and still getting 12-14ppm tds after the membrane, both at startup and hours into the water run. The water from the spectraselect I replaced was consistently 1-2ppm at startup, and somewhere between 4-7 ppm after running for a few hours (depending on the tap water temperature).
I checked the membrane, it seems to be fully seated.
This is my third Spectra Select membrane, and I've never had this problem before.

What am I missing? Is it possible the membrane has been compromised?


Tigé21v is online now   Reply With Quote
Old 08/27/2018, 11:23 AM   #2
SpectraPure
RC Sponsor
 
SpectraPure's Avatar
 
Join Date: Jun 2003
Posts: 4,657
Hey Tige21v,

I sincerely apologize for the late response. We have been having issues receiving notifications via email on Reef Central.

Can you please do me a favor and send me an email at [email protected]?

I look forward to resolving this with you!


__________________
Innovators in water technology.
Since 1985!
SpectraPure is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -6. The time now is 10:53 PM.


TapaTalk Enabled

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Use of this web site is subject to the terms and conditions described in the user agreement.
Reef CentralTM Reef Central, LLC. Copyright ©1999-2014
User Alert System provided by Advanced User Tagging v3.3.0 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.